use strict;
my $str = 'Hi, you!
No under_score!
* rem punct then spaces ';
my $regex = qr/^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";