const regex = /^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^a-zA-Z\\n]+|[^a-zA-Z\\n]+$|[^a-zA-Z\\s]+', 'gm')
const str = `Hi, you!
No under_score!
* rem punct then spaces `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);