using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+";
string substitution = @"";
string input = @"Hi, you!
No under_score!
* rem punct then spaces ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}