$re = '/^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+/m';
$str = 'Hi, you!
No under_score!
* rem punct then spaces ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;