#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^a-zA-Z\n]+|[^a-zA-Z\n]+$|[^a-zA-Z\s]+"
Local $sString = "Hi, you!" & @CRLF & _
" No under_score!" & @CRLF & _
" * rem punct then spaces "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)