# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\(XYZ\).*/.*\(XYZ\).*/g;t' <<< "This text with (XYZ) and more"