use strict;
my $str = 'This text with (XYZ) and more';
my $regex = qr/.*\(XYZ\).*/p;
my $subst = '.*\\(XYZ\\).*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";