re = /.*\(XYZ\).*/
str = 'This text with (XYZ) and more'
subst = '.*\\(XYZ\\).*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result