import Foundation
let pattern = #".*\(XYZ\).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This text with (XYZ) and more"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".*\(XYZ\).*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)