import re
regex = re.compile(r".*\(XYZ\).*")
test_str = "This text with (XYZ) and more"
subst = ".*\\(XYZ\\).*"
result = regex.sub(subst, test_str)
if result:
print(result)