#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*\(XYZ\).*"
Local $sString = "This text with (XYZ) and more"
Local $sSubst = ".*\(XYZ\).*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)