#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?usi){% if(.+?) %}((?>(?R)|.)*?){% endif %}"
Local $sString = "{% if aaa %}" & @CRLF & _
"123" & @CRLF & _
"{% endif %}" & @CRLF & _
"" & @CRLF & _
"{% if aaa %}" & @CRLF & _
" {% if bbb %}" & @CRLF & _
" 123" & @CRLF & _
" {% endif %}" & @CRLF & _
"" & @CRLF & _
" 456" & @CRLF & _
"" & @CRLF & _
" {% if ccc %}" & @CRLF & _
" {% if ddd %}" & @CRLF & _
" 789" & @CRLF & _
" {% endif %}" & @CRLF & _
" {% endif %}" & @CRLF & _
"{% endif %}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")