import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{% if(.+?) %\\}((?>(?R)|.)*?)\\{% endif %\\}";
final String string = "{% if aaa %}\n"
+ "123\n"
+ "{% endif %}\n\n"
+ "{% if aaa %}\n"
+ " {% if bbb %}\n"
+ " 123\n"
+ " {% endif %}\n\n"
+ " 456\n\n"
+ " {% if ccc %}\n"
+ " {% if ddd %}\n"
+ " 789\n"
+ " {% endif %}\n"
+ " {% endif %}\n"
+ "{% endif %}";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}