import re
regex = re.compile(r"{% if(.+?) %}((?>(?R)|.)*?){% endif %}", flags=re.UNICODE | re.DOTALL | re.IGNORECASE)
test_str = ("{% if aaa %}\n"
"123\n"
"{% endif %}\n\n"
"{% if aaa %}\n"
" {% if bbb %}\n"
" 123\n"
" {% endif %}\n\n"
" 456\n\n"
" {% if ccc %}\n"
" {% if ddd %}\n"
" 789\n"
" {% endif %}\n"
" {% endif %}\n"
"{% endif %}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")