$re = '/{% if(.+?) %}((?>(?R)|.)*?){% endif %}/usi';
$str = '{% if aaa %}
123
{% endif %}
{% if aaa %}
{% if bbb %}
123
{% endif %}
456
{% if ccc %}
{% if ddd %}
789
{% endif %}
{% endif %}
{% endif %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);