const regex = /{% if(.+?) %}((?>(?R)|.)*?){% endif %}/gusi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{% if(.+?) %}((?>(?R)|.)*?){% endif %}', 'gusi')
const str = `{% if aaa %}
123
{% endif %}
{% if aaa %}
{% if bbb %}
123
{% endif %}
456
{% if ccc %}
{% if ddd %}
789
{% endif %}
{% endif %}
{% endif %}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}