re = /{% if(.+?) %}((?>(?R)|.)*?){% endif %}/i
str = '{% if aaa %}
123
{% endif %}
{% if aaa %}
{% if bbb %}
123
{% endif %}
456
{% if ccc %}
{% if ddd %}
789
{% endif %}
{% endif %}
{% endif %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end