using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\r|\n|^<]*(<a([^*>]+>)|<\/a>)";
string input = @"juabsdfsadfsdfsf<a href=""><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=""><a href=""></a><div class=""block"">
<a href=""/"">
<div class=""divInside""></div>
<img src=""/bla"" /><div class=""block"">
<a href=""/"">
<div class=""divInside""></div>
<img src=""/bla"" />
<p>Parargraph<div class=""block"">
<a href=""/"">
<div class=""divInside""></div>
<img src=""/bla"" />
<p>Parargraph</p>
</a>
</div></p>
</a>
</div>
<p>Parargraph</p>
</a>
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}