import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\r|\\n|^<]*(<a([^*>]+>)|<\\/a>)";
final String string = "juabsdfsadfsdfsf<a href=\"\"><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=\"\"><a href=\"\"></a><div class=\"block\">\n"
+ " <a href=\"/\">\n"
+ " <div class=\"divInside\"></div>\n"
+ " <img src=\"/bla\" /><div class=\"block\">\n"
+ " <a href=\"/\">\n"
+ " <div class=\"divInside\"></div>\n"
+ " <img src=\"/bla\" />\n"
+ " <p>Parargraph<div class=\"block\">\n"
+ " <a href=\"/\">\n"
+ " <div class=\"divInside\"></div>\n"
+ " <img src=\"/bla\" />\n"
+ " <p>Parargraph</p>\n"
+ " </a>\n"
+ "</div></p>\n"
+ " </a>\n"
+ "</div>\n"
+ " <p>Parargraph</p>\n"
+ " </a>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}