import re
regex = re.compile(r"[\r|\n|^<]*(<a([^*>]+>)|<\/a>)")
test_str = ("juabsdfsadfsdfsf<a href=\"\"><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=\"\"><a href=\"\"></a><div class=\"block\">\n"
" <a href=\"/\">\n"
" <div class=\"divInside\"></div>\n"
" <img src=\"/bla\" /><div class=\"block\">\n"
" <a href=\"/\">\n"
" <div class=\"divInside\"></div>\n"
" <img src=\"/bla\" />\n"
" <p>Parargraph<div class=\"block\">\n"
" <a href=\"/\">\n"
" <div class=\"divInside\"></div>\n"
" <img src=\"/bla\" />\n"
" <p>Parargraph</p>\n"
" </a>\n"
"</div></p>\n"
" </a>\n"
"</div>\n"
" <p>Parargraph</p>\n"
" </a>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")