re = /[\r|\n|^<]*(<a([^*>]+>)|<\/a>)/
str = 'juabsdfsadfsdfsf<a href=""><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=""><a href=""></a><div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" /><div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" />
<p>Parargraph<div class="block">
<a href="/">
<div class="divInside"></div>
<img src="/bla" />
<p>Parargraph</p>
</a>
</div></p>
</a>
</div>
<p>Parargraph</p>
</a>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end