// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\r|\n|^<]*(<a([^*>]+>)|<\/a>)").unwrap();
let string = "juabsdfsadfsdfsf<a href=\"\"><h1></h1></a> sdfsdfsdf <h2>sdfsdfs</h2> <div class=\"\"><a href=\"\"></a><div class=\"block\">
<a href=\"/\">
<div class=\"divInside\"></div>
<img src=\"/bla\" /><div class=\"block\">
<a href=\"/\">
<div class=\"divInside\"></div>
<img src=\"/bla\" />
<p>Parargraph<div class=\"block\">
<a href=\"/\">
<div class=\"divInside\"></div>
<img src=\"/bla\" />
<p>Parargraph</p>
</a>
</div></p>
</a>
</div>
<p>Parargraph</p>
</a>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}