#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^feat(\([\w-]*\))?:|✨"
Local $sString = "feat: ABC-123 message" & @CRLF & _
"feat: message" & @CRLF & _
"✨: message" & @CRLF & _
"" & @CRLF & _
"feat : ABC-123 message" & @CRLF & _
"feat!: message" & @CRLF & _
"feat(scope)!: message" & @CRLF & _
"feat(scope-scope)!: message" & @CRLF & _
"💥message" & @CRLF & _
"fix: message" & @CRLF & _
"feat(scope scope)!: message" & @CRLF & _
"feat(scope): ABC-123 message" & @CRLF & _
"feat(scope): message" & @CRLF & _
"feat(scope): ABC-123 message" & @CRLF & _
"feat(scope-scope): ABC-123 message" & @CRLF & _
"feat(scope scope): ABC-123 message" & @CRLF & _
"fix(scope): message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")