using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^feat(\([\w-]*\))?:|✨";
string input = @"feat: ABC-123 message
feat: message
✨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
fix: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
fix(scope): message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}