import re
regex = re.compile(r"^feat(\([\w-]*\))?:|✨", flags=re.MULTILINE)
test_str = ("feat: ABC-123 message\n"
"feat: message\n"
"✨: message\n\n"
"feat : ABC-123 message\n"
"feat!: message\n"
"feat(scope)!: message\n"
"feat(scope-scope)!: message\n"
"💥message\n"
"fix: message\n"
"feat(scope scope)!: message\n"
"feat(scope): ABC-123 message\n"
"feat(scope): message\n"
"feat(scope): ABC-123 message\n"
"feat(scope-scope): ABC-123 message\n"
"feat(scope scope): ABC-123 message\n"
"fix(scope): message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")