use strict;
my $str = 'feat: ABC-123 message
feat: message
✨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
fix: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
fix(scope): message';
my $regex = qr/^feat(\([\w-]*\))?:|✨/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}