package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^feat(\([\w-]*\))?:|✨`)
var str = `feat: ABC-123 message
feat: message
✨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
fix: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
fix(scope): message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}