re = /^feat(\([\w-]*\))?:|✨/m
str = 'feat: ABC-123 message
feat: message
✨: message
feat : ABC-123 message
feat!: message
feat(scope)!: message
feat(scope-scope)!: message
💥message
fix: message
feat(scope scope)!: message
feat(scope): ABC-123 message
feat(scope): message
feat(scope): ABC-123 message
feat(scope-scope): ABC-123 message
feat(scope scope): ABC-123 message
fix(scope): message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end