#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)http:\/\/maps\.google\.com\/maps\?q=.*&ll=(\d*\.*\d*),(\d*\.*\d*).*"
Local $sString = "http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")