$re = '/http:\/\/maps\.google\.com\/maps\?q=.*&ll=(\d*\.*\d*),(\d*\.*\d*).*/i';
$str = 'http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);