package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)http:\/\/maps\.google\.com\/maps\?q=.*&ll=(\d*\.*\d*),(\d*\.*\d*).*`)
var str = `http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}