re = /http:\/\/maps\.google\.com\/maps\?q=.*&ll=(\d*\.*\d*),(\d*\.*\d*).*/i
str = 'http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17'
# Print the match result
str.match(re) do |match|
puts match.to_s
end