using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/maps\.google\.com\/maps\?q=.*&ll=(\d*\.*\d*),(\d*\.*\d*).*";
string input = @"http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}