import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/maps\\.google\\.com\\/maps\\?q=.*&ll=(\\d*\\.*\\d*),(\\d*\\.*\\d*).*";
final String string = "http://maps.google.com/maps?q=22.2769,114.227&ll=22.2769,114.227&z=17";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}