#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""[^"]+"(*SKIP)(*F)|:D"
Local $sString = ":D :D ":D" :D:D:D:D"
Local $sSubst = "^"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)