using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]+""(*SKIP)(*F)|:D";
string substitution = @"^";
string input = @":D :D "":D"" :D:D:D:D";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}