import Foundation
let pattern = #""[^"]+"(*SKIP)(*F)|:D"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #":D :D ":D" :D:D:D:D"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"^"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)