$re = '/"[^"]+"(*SKIP)(*F)|:D/';
$str = ':D :D ":D" :D:D:D:D';
$subst = "^";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;