const regex = /"[^"]+"(*SKIP)(*F)|:D/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"[^"]+"(*SKIP)(*F)|:D', 'g')
const str = `:D :D ":D" :D:D:D:D`;
const subst = `^`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);