#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$"
Local $sString = "ABC-DEF-17-021" & @CRLF & _
"AB-DEF-17-021" & @CRLF & _
"ABC-DEF-1" & @CRLF & _
"ABC-DEF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")