import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$";
final String string = "ABC-DEF-17-021\n"
+ "AB-DEF-17-021\n"
+ "ABC-DEF-1\n"
+ "ABC-DEF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}