re = /^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$/m
str = 'ABC-DEF-17-021
AB-DEF-17-021
ABC-DEF-1
ABC-DEF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end