package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$`)
var str = `ABC-DEF-17-021
AB-DEF-17-021
ABC-DEF-1
ABC-DEF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}