import re
regex = re.compile(r"^[A-Za-z].{2}-[A-Za-z].{2}-([0-9]|[0-9].{1}-[0-9].{2})$", flags=re.MULTILINE)
test_str = ("ABC-DEF-17-021\n"
"AB-DEF-17-021\n"
"ABC-DEF-1\n"
"ABC-DEF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")