#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(a|b)\1*\b"
Local $sString = "aaa" & @CRLF & _
"bbb" & @CRLF & _
"aba" & @CRLF & _
"bab" & @CRLF & _
"a" & @CRLF & _
"ab" & @CRLF & _
"b" & @CRLF & _
"ba" & @CRLF & _
"baba" & @CRLF & _
"abab" & @CRLF & _
"" & @CRLF & _
"a" & @CRLF & _
"aa" & @CRLF & _
"aaa" & @CRLF & _
"b" & @CRLF & _
"bb" & @CRLF & _
"bbb" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"this is a test or bb test ababa aaaab"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")