const regex = /\b(a|b)\1*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(a|b)\\1*\\b', 'gm')
const str = `aaa
bbb
aba
bab
a
ab
b
ba
baba
abab
a
aa
aaa
b
bb
bbb
this is a test or bb test ababa aaaab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}