using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(a|b)\1*\b";
string input = @"aaa
bbb
aba
bab
a
ab
b
ba
baba
abab
a
aa
aaa
b
bb
bbb
this is a test or bb test ababa aaaab";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}