import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(a|b)\\1*\\b";
final String string = "aaa\n"
+ "bbb\n"
+ "aba\n"
+ "bab\n"
+ "a\n"
+ "ab\n"
+ "b\n"
+ "ba\n"
+ "baba\n"
+ "abab\n\n"
+ "a\n"
+ "aa\n"
+ "aaa\n"
+ "b\n"
+ "bb\n"
+ "bbb\n\n\n"
+ "this is a test or bb test ababa aaaab";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}