$re = '/\b(a|b)\1*\b/m';
$str = 'aaa
bbb
aba
bab
a
ab
b
ba
baba
abab
a
aa
aaa
b
bb
bbb
this is a test or bb test ababa aaaab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);