re = /\b(a|b)\1*\b/m
str = 'aaa
bbb
aba
bab
a
ab
b
ba
baba
abab
a
aa
aaa
b
bb
bbb
this is a test or bb test ababa aaaab'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end